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Verifying Signatures 
After a digital signature has been applied to a document, it can be verified, either by the 
person who signed the document or by someone else to whom the document has been 
sent.  See How Digital Signatures Work for a description of the internal workings of the 
verification process. 

Before someone else can verify a digital signature that you have applied to a document, 
the other person must do two things: 

• Install the Banjo plug-in on his or her computer.  A free Banjo Verify plug-in is 
available for people who need to verify signatures only (not create them) and it 
works with the free Adobe Reader and with Adobe Acrobat. 

• Import the digital certificate that was used to create the digital signature.  See 
Importing and Exporting Certificates for more information. 
 

You can choose to verify all digital signatures automatically whenever a document is 
opened in Acrobat (see Setting Global Options for more information).  If this option is not 
set, or if signatures need to verified again after the document is already open, this can 
be done in one of two ways. 

• Choose Banjo > Verify Signatures to verify all digital signatures in the 
document. 

• Choose the hand tool (the  icon in the Basic toolbar) and click on a single 
digital signature – only that signature will be checked for validity. 
 

The following example illustrates the signature verification process.  Note that the fields 
for date and time signed have been added in the Signature Designer, along with an 
image of a written signature.  

The valid signature looks like this: 

 
Here, the digital signature appearance is as it was defined in the Signature Designer.  
The Validity field displays the text “VALID”, which is the default text for this field.  

Note the green checkmark in the upper left corner.  This icon is added by Acrobat (in 
versions 6 and later) to indicate a valid signature.  The icon is not a part of the signature 
appearance, and it does not display when the document is printed.   
 

If a signature is invalid, it appears like this: 

 
The Validity field displays the text defined for the Invalid state, while the Acrobat-added 
icon in the upper left corner shows an X to indicate an invalid signature. 

A signature can only be invalid for two reasons: 

• The document has been changed since the time it was signed. 

• The certificate used to sign the document is expired or cannot be verified to be 
authentic. 
 

 
Be careful about certificate expiration dates.  Especially if you are considering archiving 
documents that have been digitally signed, keep in mind that when the a certificate 
expires, all signatures created with that certificate will become invalid.  One way around 
this problem is to use a self-signed certificate, and to check the Ignore expiration 
dates… box in the Options settings.  If you are using a certificate issued by a 
Certification Authority, the only solution is to obtain a certificate with a sufficiently distant 
expiration date. 
 

 
An unverified signature appears like this: 

 
A signature is unverified if it cannot be checked for some reason.  The most common 
reasons for an unverified appearance are: 

• The certificate used to create the signature is not installed on the computer that 
is being used to verify it.  See Importing and Exporting Certificates for 
information. 

• The Banjo or Banjo Verify plug-in is not installed on the verifying computer.  The 
plug-in is required to verify signatures created by it. 

• A change has been made to the PDF file, but the file has not yet been saved.  
The signature will display as Unverified until the file is saved and signatures are 
verified, at which point it will change to Invalid. 
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Setting Global Options 
The global Op ions dialog box is accessed through Banjo > Options.  This dialog box 
controls options that apply to the user interface in general, and not to any specific 
profile. 

 

 
 

The options available in this dialog box are: 

Verify signatures when document is opened 
If checked, then all digital signatures will be verified as soon as a document is 
opened in Acrobat.  If this box is not checked, then you must specifically instruct the 
software to check signatures.  See Verifying Signatures for more information. 

For this option to take effect, you must exit from Acrobat and then re-start the 
application. 

Signing tools stay active 
If checked, then once picked, the Banjo signing tools (the pen icons in the Banjo 
toolbar) will remain selected until a different tool is chosen.  This makes it easier to 
apply multiple signatures to a document. 

Overwrite file / Save as new file  
When a document is signed, it is automatically saved.  Choose an option here to 
indicate if the existing file should be overwritten or if a new PDF file should be 
created with the digital signature in it. 

Require Trusted Root verification for self-signed certificates 
If checked, then self-signed certificates will be required to have a Trusted Root 
certificate to verify them.  For more information on Trusted Root certificates, see 
Managing Digital Certificates and Importing and Exporting Certificates.  By default, 
when you create a self-signed certificate a Trusted Root certificate is also created for 
it.  This option is most useful when importing a self-signed certificate from someone 
else to use in verifying that person’s signature.  By unchecking this box, you will only 
need to import the self-signed certificate into one certificate store (the Other People 
or Intermediate Certification Authorities store) and not into the Trusted Root store as 
well.  Because a self-signed certificate validates itself, there is no difference in 
security if this box is checked or unchecked – it is simply a matter of convenience.   

Ignore expiration dates of self-signed certificates when verifying 
signatures 
Usually a certificate is considered invalid if its expiration date has passed.  For self-
signed certificates, however, this consideration is less important, as there is no 
certification authority attesting to their validity for a limited period of time.  If this 
box is checked, then expired self-signed certificates will be permitted when a 
signature is verified. 

Display warning when verifying a signature with a missing certificate 
If checked, then a warning message will be displayed when a signature cannot be 
verified because the signing certificate is not installed.  If not checked, then no 
message will be displayed.  In either case, the signature will display as Unverified. 

Profiles directory 
The default directory in which the Banjo plug-in will search for profiles (files with a 
.LTS file type).  The value of this field may be changed by clicking on the Browse… 
button. 
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Managing Digital Certificates 
Digital certificates are kept in a special location on your computer, managed and 
controlled by Microsoft Windows.  The Banjo plug-in accesses these certificates through a 
standard Windows dialog box.   

The Certificates dialog box may be opened in two different ways: 

• Select Manage Certificates from the Banjo menu. 

• Choose Banjo > User Profile Settings, and click the Manage Certificates 
button. 

A dialog box similar to the one shown below will appear.  If you do not currently have 
any certificates installed for your personal use, then the window may appear blank.  See 
Obtaining a Digital Certificate for information on installing a personal certificate. 

 

 
 

Each certificate has several fields listed for it in the dialog box: 

Issued To This is the name of the certificate – the individual or entity to which 
the certificate belongs, and with whose identity the encryption keys 
in the certificate are associated. 

Issued By This is the entity that issued the certificate to the owner and attests 
to the owner’s identity.  For a self-signed certificate, this field is the 
same as the ssued To field.  For a certificate issued by a 
Certification Authority (CA), this field contains the name of the CA. 

I
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Expiration  The date on which the certificate expires and can no longer be used 
for signing documents. 

Friendly Name An optional field, sometimes used to provide additional information 
about the certificate holder. 

 

There are a number of tabs along the top (Personal, Other People, etc.).  These 
represent Cer ificate S ores, similar to file folders on the desktop.  Each certificate store 
holds certificates with a different level of trust, and a corresponding different use: 

Personal Certificates issued to an individual user.  These can be used for 
creating digital signatures.  Certificates in this store may be either 
self-signed or issued by a CA. 

Other People Certificates received from other people, and installed onto your 
computer for the purpose of verifying digital signatures from these 
other individuals.  Before you can verify a digital signature from 
someone else, you must obtain and install their certificate on your 
computer.  Similarly, you must provide your certificate to anyone 
who needs to verify digital signatures that you create. 

Intermediate This store is generally used for special purposes, often associated 
with Public Key Infrastructures (PKI).  However, for Windows 98 and 
Windows 2000 users, this store is also used to import certificates 
from other people, because the Other People store is not available 
on those operating systems.   

Trusted Root Certificates belonging to Certification Authorities.  These are all self-
signed, because a Certification Authority is accepted as a trusted 
entity.  Any certificate in the Personal, Other People, or Intermediate 
Certification Authorities store that is issued by a CA can only be 
trusted if the certificate of the CA is in the Trusted Root Certification 
Authorities store. 

 

The Trusted Root Certification Authorities store, and the Intermediate Certification 
Authorities store, come pre-populated with certificates when your operating system is 
installed.  The certificates that are located in these stores by default belong to 
Certification Authorities that have been verified by Microsoft as being trusted CA’s. 
 

 
Be careful about installing certificates into the Trusted Root Certification Authorities store 
– any certificate you install there is automatically identified as being trusted and may be 
used to validate other Personal certificates that are sent to you.  Confirm that the Root 
certificate is from a reputable source before installing it on your computer. 
 

 

To delete a certificate from your computer (in any one of the certificate stores) just 
select the certificate name and click the Remove button.   

The other buttons (Advanced and View) can be used to obtain additional information 
about the certificate or set advanced options.  
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Importing and Exporting Certificates 
If you plan to exchange digitally signed documents with other people, you will first need 
to exchange digital certificates.  A digital signature can only be verified on another 
computer if the certificate used to sign the document has been imported onto the other 
computer.   

It is not necessary, though, to import the certificate of someone to whom you are only 
sending a signed document.  Another person’s certificate is only needed when verifying 
that person’s signature. 

 
As outlined in How Digital Signatures Work, each certificate contains two keys – a private 
key, which is kept secure on the owner’s computer, and a public key, which can be 
distributed freely.  Any data that is encrypted with the private key can be decrypted with 
the public key.   
 

 
When exporting a Personal certificate for use by someone else, be sure to only export 
the public key, not the private key.  The Certificate Export Wizard that will be used to do 
the exporting will ask if the private key should be exported.  Usually, the answer should 
be no. 

The only case in which you would want to export the private key is if you are transferring 
the certificate to another computer for your own use.  For instance, if you have installed 
a certificate on your desktop computer, and want to have it installed on a laptop so that 
the laptop can be used to sign documents, then the private key should be exported along 
with the public key. 
 

 
To export a certificate: 

• Open the Cer ificates dialog box (see t

t
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Managing Digital Certificates). 

• Select the certificate to be exported. 

• Click the Export… button 

• Follow the prompts in the Certificate Export Wizard.  

• When the wizard asks for an Expor  File Format, choose the default unless you 
specifically know that a different format is required. 

• When the wizard asks for the file name to export, click the Browse… button to 
indicate the directory in which the exported certificate will be placed. 

The exported file can now be emailed or transferred on a floppy disk or CD to another 
person.  When that person receives the file, it will need to be imported into a certificate 
store before it can be used. 
 

To import a certificate: 

• Open the Cer ificates dialog box (see Managing Digital Certificates). 

• Click the tab for the certificate store into which the certificate will be imported. 

o For public-key-only certificates from other people (which will be used 
only for verifying digital signatures) choose the Othe  People store.  If 
you are using Windows 98 or Windows 2000, the Other People store will 
not be available for import.  In this case, use Intermediate Certification 
Authorities as your store to import certificates from other people. 

o For private key certificates (transferred from another computer for your 
use) choose the Personal store. 

o For Trusted Root certificates choose the Trusted Root Certification 
Authorities store. 

• Click the Import… button. 

• Follow the prompts in the Certificate Import Wizard. 

 
It is also possible to import a certificate simply by double-clicking on the certificate name 
or icon in the Windows file explorer.  This method can be tricky, however, because you 
must be sure to explicitly tell the Import Wizard which store to use for the import.  The 
default choice when using the double-click method is to allow the wizard to automatically 
decide where to import the certificate.  You must click the other option (labeled Place all 
certificates in the following store) and browse to either the Personal or Other People or 
Intermediate Certification Authorities store as appropriate. 
 

Sometimes you may import a certificate from another person, and signatures will show 
as unverified because the imported certificate cannot be confirmed as valid.  The most 
common reason for this is that the signing certificate must be validated by a certificate in 
the Trusted Root Certification Authori ies store.  The procedure for fixing this problem is 
different depending on whether the signing certificate is issued by a Certification 
Authority or is self-signed. 

t

If the signing certificate is issued by a Certification Authority (CA), then that CA’s 
certificate must be in the Trusted Root Certification Authorities store: 

• Obtain the Root certificate for that CA (by having the certificate signer export it 
from his or her computer) 

• Import the Root certificate for the CA into your own Trusted Root Certification 
Authorities store.   

If a signer’s certificate is self-signed, there are two choices: 

• Import the self-signed certificate into both the Other People store and the 
Trusted Root Certification Authorities store. 

• Use the Options dialog box to allow the self-signed certificate to be validated 
without a Trusted Root certificate (see Setting Global Options for more 
information). 
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Batch Printing 
The Batch Print feature is available as an option with the Banjo plug-in and the Banjo 
Verify plug-in.  This feature allows you to compile a list of PDF documents and then print 
them all at once.   

Generally, print shop staff and reprographers will make the most use of batch printing.  
These users print many documents every day, and the ability to start a batch print 
operation and leave it running unattended is an important time saver. 

Each print shop has its own ways of working, and the Batch Print feature has been 
designed to be flexible so that it can be integrated into many different settings.  
 

Reprographers and print shops may need to use Batch Print to create TIFF or other 
image files from signed PDF documents, so that the TIFF files can be submitted to plot 
management software such as PlotWorks or ReproDesk.  If you need to do this type of 
processing, be sure to read Using PDFCreator with the Banjo Plug-in. 
 

Before using the batch print feature, make sure that Acrobat and the Banjo plug-in are 
set up correctly: 

• Select File > Print Setup in Acrobat or Reader to select the current printer and 
any print options.  Options selected in the Print Setup dialog box will be used 
during the batch print operation. 

• Select Banjo > Options and be sure that the Verify signatures when documen  
is opened box is checked.  If this box is not checked, then all signatures will 
print as Unverified. 

• Select Banjo > Options and verify that the checkbox for Display warning when 
verifying a signature with a missing certificate is checked or unchecked, as you 
prefer.  If this box is checked, then a warning dialog box may hold up printing if 
a missing certificate is encountered.  If the box is not checked, a signature with a 
missing certificate will print as Unverified and there will be no warning.  See 
Importing and Exporting Certificates for more information. 

Next, select Banjo > Batch Print to open the Batch Print dialog box.  It will look like 
this: 

 

 
 
Now build a list of files to be printed: 

• Click on Add Files and browse to locate files that you want to print.   

• You can click on Add Files several times to select files from different directories. 

• Files may also be deleted from the list by selecting them and clicking on 
Remove Files. 

• New files are always added to the bottom of the list, in alphabetical order. 

• The entire list may be sorted by file name or by directory path by clicking on the 
column heading (File or Path) at the top of the list. 

There are a couple of option settings as well: 

• Print each page as a separate job will run a separate Print command for 
each page in the PDF.  This is slower than printing all pages together at once, 
but it may be useful if you are printing to a “virtual” printer that creates a TIFF 
or other image file, and you want to create multiple single-page files from one 
multi-page PDF.  
You will need to give each file a unique name (or your printer driver will need to 
append a unique identifier, such as the time of day or a sequence number, to 
each file) in order to prevent each page from overwriting the same file. 

 
If you are using the PDFCreator print driver to create TIFF files from PDFs, there 
is a much faster way to accomplish this same thing – be sure to read Using 
PDFCreator with the Banjo Plug-in for more information. 
 

• Choose paper source by PDF page size is identical to the setting by the 
same name in the Acrobat/Reader Print dialog box.  If selected, this option will 
enable Acrobat to choose a different page size for each page of the document, 
depending on the document dimensions.   

This setting is particularly useful if you are printing several different documents 
that have different page sizes, or a multi-page document that has different size 
pages.  Unless you are sure that you do not want this option, it is best to leave it 
selected. 

This option is not available for Acrobat and Reader version 5.   

 

Once the list of files is complete, start processing them: 

• Click on Print – the files will be printed one by one until the entire list has been 
processed. 

• At any time while the list of file is being processed, you can click on Pause and 
batch printing will stop after processing of the current file is complete.  It may 
take a while for the Pause button to have an effect, as the file currently being 
processed must be completely printed before Batch Print will pause. 

• While batch print is paused, you may modify the list of files using the Add Files 
and Remove Files buttons, or you may exit from batch print to cancel all 
remaining printing. 
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Troubleshooting 
This chart lists common problems and the solutions for them.  Please check this list 
carefully before submitting a support request.   

If an answer cannot be found, check the Support page for additional resources. 

 

Installation, Startup and Performance 

Problem Likely cause Solution 
There is an Acrobat 
setting to allow only plug-
ins “certified” by Adobe to 
be loaded.  The Banjo 
plug-in is not certified and 
will be blocked if this 
option is set. 

Acrobat version 5: 

• Go to Edit > Preferences > General > Options 

• Un-check the Certified Plug-ins Only box. 

Acrobat version 6 and 7: 

• Go to Edit > Preferences > Startup 

• Un-check the Use only certified plug-ins box. 

 

Exit and restart Acrobat 

The Banjo menu 
does not appear in 
the menu bar 

The plug-in has been 
installed for the incorrect 
version of Acrobat. 

During the installation process, you will be prompted for 
the directory in which the plug-in should be installed.  

To fix this problem, just re-install the plug-in and specify 
the correct directory. 

The Banjo menu 
appears, but not the 
toolbar with the pen 
icons. 

The Banjo toolbar is not 
being displayed. 

Right-click on any toolbar, and select Banjo from the 
menu that appears. 

Acrobat version 5 uses 
a slower method of 
applying signatures than 
do versions 6 through 8. 

Upgrade to the newest version of Acrobat.  Click here to 
go to the Adobe website. 

The document is very 
large. 

Large, multi-page documents take longer to process 
because there is more information to compute for the 
signature.  The only solution is to reduce the size of the 
document, or just live with the required processing time. 

It seems to take a 
long time to apply 
the signature when I 
sign a document 

The document has many 
different digital signatures 
applied to it. 

When many signatures are applied (more than ten or so) 
each successive signature will take noticeably longer to 
apply.  This is a function of the processing time required 
to compute the new signature codes.   

If you are applying an identical signature to the same 
location in several pages, try using the Multi-Sign Mode 
instead of individual signatures.   

If the structure of the document does not lend itself to 
using Multi-Sign mode, try to break the document up into 
several separate documents, so that each PDF has fewer 
than ten signatures. 

 

Signature Appearance and Verification  

Problem Likely cause Solution 
When I open up the 
Signature Designer, 
everything looks too 
small. 

The zoom factor is too 
small. 

Zoom in more on the area of the PDF that will receive the 
signature, and then re-open the Signature Designer. 

Usually a zoom factor of 100% works well as a starting 
point. 

When I open the 
signature designer, I 
can’t see all the 
elements in my 
signature 
appearance. 

The zoom factor is too 
large. 

Zoom out in the PDF (try a zoom factor of 100%) and 
then re-open the signature designer. 

The signature appearance 
you have defined uses 
elements that require a 
lot of space.  Reducing 
these elements may solve 
the problem.  This effect 
will be most noticeable 
when multiple signatures 
are applied to one PDF. 

Try the following to reduce the size of the signature 
appearance: 

• Use black and white (1-bit) or grayscale (8-bit) 
images rather than full color (24-bit) images. 

• Resample bitmaps down to the minimum acceptable 
resolution.  Hi-res bitmaps take up a lot of space. 

• Reduce the number of fonts that are used.  Every 
font that appears in a signature must be saved with 
the file, so if you are using more than 2 or 3 fonts, 
this could have a significant effect. 

When I apply a 
signature to a PDF, 
the size of the file 
increases a lot. 

There are many separate, 
individual signatures 
applied to the PDF. 

When many signatures are applied, each signature will 
increase the size of the PDF more than the previous 
signature did.  This is due to the overhead that Adobe 
Acrobat associates with each signature.   

If you are applying an identical signature to the same 
location in several pages, try using the Multi-Sign Mode 
instead of individual signatures.   

If the structure of the document does not lend itself to 
using Multi-Sign mode, try to break the document up into 
several separate documents, so that each PDF has fewer 
than ten signatures. 

The other person does 
not have the Banjo plug-
in installed on his or her 
computer. 

Digital signatures created with the Banjo plug-in can only 
be verified by either the Banjo plug-in or the free Banjo 
Verify plug-in.  The free Banjo Verify plug-in works with 
either Adobe Reader or Adobe Acrobat, and it is available 
from the LineType Software, Inc. website. 

I signed a document 
and sent it to 
someone, but they 
can’t verify my 
signature 

The other person does 
not have the digital 
certificate that was used 
to create the signature. 

See the troubleshooting tip directly below this one for 
more information. 

A signature cannot be 
verified unless the 
certificate used to create 
it has been installed. 

• Contact the person who signed the document, and 
ask that he or she export the public-key-only version 
of the certificate and send it to you.   

• Install the certificate on your computer in the Other 
People store.   

• See Importing and Exporting Certificates for more 
detailed information. 

An error message 
appears saying that 
the digital certificate 
used to sign the 
document is not 
installed on my 
computer. 

This warning message 
can also be turned off 

Select Banjo > Options and uncheck the box for Display 
warning when verifying a signature wi h a missing 
certificate. 

t

An error message 
appears saying that 
“…this document 
requires a Trusted 
Root Certification 
Authority certificate 
for validation.” 

A signature in the 
document has been 
signed with a certificate 
that can only be validated 
by another certificate in 
the Trusted Root store, 
and this Trusted Root 
certificate is missing. 

There are two possible solutions: 

• If the signature was created with a self-signed 
certificate, you can disable checking for Trusted Root 
certificates.  See the Options dialog box. 

• If the signature was created with a certificate issued 
by a Certification Authority (CA), then the Trusted 
Root certificate from the CA must be installed on 
your computer first.  Contact the signer of the 
document, and ask for the Trusted Root certificate to 
be exported and sent to you.  See Importing and 
Exporting Certificates – but verify the identity of the 
CA first, and be sure it is legitimate before importing 
the certificate into your Trusted Root store. 

A signature is 
showing as INVALID.  
Why is this? 

Either the contents of the 
file have changed, or the 
certificate used to sign 
the document is invalid or 
expired. 

See Verifying Signatures for more information, including a 
possible work-around for an expired self-signed 
certificate. 

I’m using Batch Print 
to print a series of 
signed PDFs.  The 
signatures all show 
as Unverified. 

The plug-in may not be 
verifying signatures when 
PDFs are opened. 

Select Banjo > Options.  Make sure that the Verify 
signatures when document is opened check box is 
checked. 

 
Continue to the next page for more Troubleshooting advice…

http://www.adobe.com/products/acrobat/main.html
http://www.linetype.com/
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Certificates 

Problem Likely cause Solution 
I’m trying to create a 
self-signed 
certificate, but I get 
an error message 
saying “Cannot 
create certificate” 

Some punctuation marks 
(commas, most notably) 
are not allowed in the 
Certificate name, or in the 
Company or Email fields. 

Try re-typing the information without using commas.  If 
this does not work, try eliminating other punctuation 
marks.  A period is allowed, however. 

When I click on the 
Manage 
Certificates button, 
I see a lot of 
certificates in the 
Personal store.  But 
these are not listed 
as available when 
I’m creating a new 
profile. 

Only valid certificates are 
listed as available for use 
in a new profile.  The 
Manage Certificates 
dialog box lists all 
certificates, whether valid 
or not. 

If a certificate is not listed in the Create New Profile 
dialog box, it is probably invalid for one of two reasons: 

• The expiration date has passed. 

• The certificate is not validated by a Trusted 
Root certificate. 

Note that even self-signed certificates are required to 
have a Trusted Root validation in order for them to be 
used to create a profile and sign a document.   

I’m trying to import 
a certificate sent to 
me by someone else, 
but I can’t find it in 
the Certificate 
Import Wizard 
“Browse” option. 

There are several possible 
file types associated with 
certificates.  You may be 
looking for the wrong 
type. 

Check the file type of the certificate you are importing.  
Be sure that the same file type is selected in the bottom 
of the Browse window for the Certificate Import wizard. 

I can’t import a 
certificate into the 
Other People store – 
the store is visible in 
the Certificates 
dialog box, but 
importing doesn’t 
work. 

On Windows 2000 and 
Windows 98 systems, the 
Other People store is not 
available, even though it 
is appears in the 
Certificates dialog box. 

Import the certificate into the Intermediate Certification 
Authorities store instead. 
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Support 
Free email support is available to all users, and we welcome reports of problems or 
suggestions for improvement. 

Support email address is info@linetype.com or visit the LineType Software, Inc. website 
at www.linetype.com  

 

For more information about the PDF format and about generating PDF files from CAD 
software or other graphics applications, visit www.linetype.com/advice  

 

Thank you for using the Banjo plug-in! 

 

mailto:info@linetype.com
http://www.linetype.com/
http://www.linetype.com/advice
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Appendices 

Using PDFCreator with the Banjo Plug-in
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Using PDFCreator with the Banjo Plug-in 
PDFCreator is an open-source (free) printer driver that can be used to create raster 
format files (as well as PDF files) from any application.  It is especially useful for 
reprographers who need to convert signed PDFs to TIFF or other formats for processing 
with plot management software.  It may be used with the Batch Print feature of the 
Banjo plug-in, or to print drawings one at a time using the Adobe Acrobat or Reader Print 
command. 

Although there are other TIFF print drivers on the market, PDFCreator has several 
advantages: 

• It is free. 

• It is fast – faster than many commercially-available drivers. 

• It supports halftoning of raster images in the PDF. 

• It has an auto-save feature that makes it well suited for batch printing. 

• It can separate multi-page documents into individual raster format documents. 

For these reasons, we recommend that anyone needing a raster format print driver 
evaluate PDFCreator. 

For more information and for a download link, see the PDFCreator page on the LineType 
Software website. 

 

There are some settings associated with PDFCreator that need to be adjusted before 
using it with the Banjo plug-in. 

Once PDFCreator has been installed on your computer, access the Options dialog box by 
choosing Windows Start > PDFCreator, then in the PDFCreator dialog box, choose 
Printer > Options. 

In the dialog box that appears, choose the Auto-Save category on the left side of the 
dialog box.  The dialog box will change to look something like this: 

 

 
 

The settings shown above are described in detail below: 

• Select the Use Auto-save checkbox so that documents printed to PDFCreator 
will automatically be named and placed in a predefined directory.  Auto-save 
mode is especially useful if the Batch Print feature is used, as the user will not be 
prompted for a filename each time a file is printed. 

• Autosave format is selected here as TIFF – this is the most common raster 
format used by reprographers, but if a different format is needed (JPEG, BMP, 
etc.) then it can be chosen from this list.  All auto-saved files will be created in 
the selected format. 

• The Filename field allows you to specify a format for the file name that will 
automatically be generated each time a document is printed.  In the example 
above, the <Title> and <DateTime> tokens are chosen from the pull-down 
list.  Using these tokens, if a file named testfile.pdf were printed using the Auto-
save feature of PDFCreator, the resulting TIFF file would be named 
testfile.pdf200504161205321.tif.  Including the date and time may be useful to 
distinguish files with the same name that have been processed at different times.   

• A directory is also specified for the auto-saved files.  All TIFF files created by 
PDFCreator will be written to this directory. 

 

Now click on the TIFF category under Formats on the left side of the dialog box.  If a 
format other than TIFF is specified in the Auto-save dialog, then click on that format 
instead to set default options.  For this example, we are assuming that the user wants to 
create black and white TIFF files, as would normally be used to create blackline plots: 

 

 

http://www.linetype.com/products/banjo/ae/pdfcreator.htm
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In the TIFF settings dialog box illustrated above, the following options have been 
chosen: 

• 400 dpi resolution.  This may be increased or decreased as necessary, 
according to the capabilities of the plotter. 

• 2 colors (Black/White) G4 fax encoding – this is the most compact format 
for black and white images.  If grayscale or color images are needed, then a 
different format should be chosen from the drop-down list.  Note that selecting a 
grayscale or color format will result in much larger TIFF files. 

 

There is one additional setting that may be very helpful when using PDFCreator.  
Sometimes, in order to integrate better into an existing print shop workflow, it is 
preferred that a multi-page PDF be converted to several single-page TIFF files.  There 
are two ways to do this: 

• The Banjo Batch Print dialog box has a checkbox option that will print each page 
as a separate print job.  This option works with PDFCreator (and all other print 
drivers as well) but it is somewhat slow because of the additional overhead 
involved. 

• The other option is available as a feature in PDFCreator – the Banjo Batch Print 
checkbox described above is left unchecked, and instead a special option flag is 
set in PDFCreator to instruct the print driver to create separate files from a multi-
page document.  This is much faster than the first method, because the 
processing is done in the print driver itself. 

To set this special option flag, the PDFCreator options file must be edited directly, using 
the Notepad application.  This feature is one of the “hidden settings” that are described 
in the PDFCreator documentation.  It is a test setting that may be included in the Options 
dialog box in later versions of PDFCreator, but it is available to users now who are willing 
to go to the trouble to edit the settings file.   

If your workflow does require producing multiple single-page TIFFs from a multi-page 
PDF, this setting is highly recommended, as it allows batch processing to work much 
faster than if the Print each page as a separate job checkbox is used. 

To set this option: 

• First make all other settings that are required, as described earlier (Auto-save 
mode, TIFF output options, etc.). 

• Click on Save in the PDFCreator options dialog box to save the settings. 

• Exit from PDFCreator. 

• Find the PDFCreator.ini settings file.  This file is usually located in C /Documents 
and Settings/Username/Application Data/PDFCreator (where Username is your 
account user name on the computer).  If you cannot find the file here, do a 
search for all files with this name, and be sure to specify that the search should 
include system folders and hidden folders.

• Copy the PDFCreator.ini file – give the copy a name like PDFCreato .ini.copy so 
that you can revert to this file later if there are problems.

• Now edit the PDFCreator.ini file in Notepad – just double-clicking on it should 
open it up for editing. 

• Scroll down (or do a search) to find the line that reads OnePagePerFile=0 and 
change the “0” to a “1”.  Now save the file and close Notepad.
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• Open the Banjo Batch Print dialog box, and make sure that the Print each page 
as a separate job checkbox is unchecked.  

• Do a test print using PDFCreator and a multi-page file.  One TIFF file should be 
created for each page in the document.  The TIFF files will automatically be 
numbered in sequence, with the sequence number following the Auto-save name 
that was specified in the Options dialog box.

In rare cases, editing the PDFCreator.ini file in this manner may cause a problem when 
you try to choose Printer > Options from the PDFCreator dialog box.  If the 
PDFCreator application crashes when this menu item is chosen, you can simply rename 
the PDFCrea or.ini.copy file back to PDFCreator.ini, and that should solve the problem.  
Or just delete the PDFCreator.ini file completely, and a new one (with default settings) 
will be made when the Options dialog box is opened again.  After changing whatever 
settings you need to in the Options dialog box, you will have to edit PDFCreator.ini with 
the Notepad application again if you wish to enable single page printing. 

 

Once these initial settings have been made, processing signed PDFs using Banjo Batch 
Print and PDFCreator is quick and easy: 

• Open Acrobat or Reader that has the Banjo with Batch Print plug-in installed. 

• Choose File > Print Setup and verify that PDFCreator is selected as the printer. 

• Choose Banjo > Batch Print  

• Select the list of PDF files to print 

• Click on Print, and all files will be automatically processed and TIFF files created 
according to the naming convention that has been set up. 

• Now process the TIFF files with plot management software, or archive as needed 
on your server. 

 

If you are using the Banjo or Banjo Verify plug-in without Batch Print, just print the 
signed PDF in the usually way (using File > Print) and choose PDFCreator as the 
printer. 
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